通达信金石区域主图指标公式

通达信金石区域主图指标公式

STICKLINE(C<O,O,C,3,0),COLORFF6600;

STICKLINE(C<O,O,C,2,0),COLORFF9900;

STICKLINE(C<O,O,C,1.2,0),COLORFFCC00;

STICKLINE(C<O,O,C,0.2,0),COLORCYAN;

STICKLINE(C>O,O,C,3,0),COLOR000099;

STICKLINE(C>O,O,C,2,0),COLOR0000CC;

STICKLINE(C>O,O,C,1.3,0),COLOR0000FF;

STICKLINE(C>O,O,C,0.3,0),COLORCC66FF;

上线:=SMA(C,6.5,1);

下线:=SMA(C,13.5,1);

上线1:=SMA(C,3,1);

下线1:=SMA(C,8,1);

BBI:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;

UPR:=BBI+3*STD(BBI,13),LINETHICK2;

DWN:=BBI-3*STD(BBI,13);

安全:=MA(CLOSE,60),LINETHICK2;

LC:=REF(CLOSE,1);

RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;

A7:=(2*C+H+L)/4;

操作:MA(A7,5),LINETHICK0;

操作1:=MA(A7,5)*1.03,LINETHICK2;

操作2:=MA(A7,5)*0.97,LINETHICK2;

VAR1:LLV(A7,21);

VAR2:HHV(A7,21);

X1:=(3*C+H+L+O)/6;

X2:=EMA(X1,10);

X3:=REF(X2,1);

X4:=(REF(HIGH,1)+REF(LOW,1))/2;

STICKLINE(X2>X3,X2,X3,4,0),COLORYELLOW,LINETHICK2;

STICKLINE(X2<X3,X2,X3,4,0),COLORF0000F,LINETHICK2;

多方:EMA(CLOSE,8);

空方:EMA(多方,20);

生命线:EMA(CLOSE,240),COLORRED;

VAR113:=(HHV(HIGH,36)-CLOSE)/(HHV(HIGH,36)-LLV(LOW,36))*100;

VAR123:=SMA(VAR113,5,1);

VAR3:=SMA(VAR123,8,1);

VAR4:=CROSS(VAR123,VAR3) AND VAR3<20;

VAR5:=CLOSE>LLV(CLOSE,60)+0.3*LLV(CLOSE,60) AND VAR4;

VAR6:=IF(CLOSE>1000,VAR4,VAR5);

DRAWICON(CROSS(多方,空方) AND CLOSE<EMA(CLOSE,60),LOW,1);

DRAWICON(VAR6,H,2);

DRAWTEXT(CROSS(多方,空方),多方*0.97,’●’),COLORYELLOW;

DRAWTEXT(CROSS(多方,空方),多方*0.968,’●’),COLORRED;

DRAWTEXT(CROSS(多方,空方),多方*0.985,’↑’),COLORYELLOW;

VAR1A:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;

VAR1B:=SMA((SMA(VAR1A,4,1)-50)*2,3,1);

VAR1C:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;

VAR1D:=SMA(VAR1C,4,1);

VAR1E:=SMA(VAR1D,3,1);

VAR1F:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;

VARE:=REF(LOW,1)*0.9;

VARF:=LOW*0.9;

VAR10:=(VARF*VOL+VARE*(CAPITAL-VOL))/CAPITAL;

VAR11:=EMA(VAR10,30);

VAR12:=CLOSE-REF(CLOSE,1);

VAR13:=MAX(VAR12,0);

VAR14:=ABS(VAR12);

VAR15:=SMA(VAR13,7,1)/SMA(VAR14,7,1)*100;

VAR16:=SMA(VAR13,13,1)/SMA(VAR14,13,1)*100;

VAR17:=BARSCOUNT(CLOSE);

VAR18:=SMA(MAX(VAR12,0),6,1)/SMA(ABS(VAR12),6,1)*100;

VAR19:=(-200)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+100;

VAR20:=VAR18<=25 AND VAR19<-95 AND VAR1F>20 AND VAR1B<-30 AND VAR1E<30 AND VAR11-CLOSE>=-0.25 AND VAR15<22 AND VAR16<28 AND VAR17>50;

金石导弹:=CROSS(VAR20,0.5) AND COUNT(VAR20=1,10)=1;

JS:DRAWICON(金石导弹,LOW-0.5,25);

JS1:DRAWTEXT(金石导弹,LOW-0.6,’金石买入’),COLORYELLOW;

VAR2A:=(CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100;

VAR2B:=SMA((SMA(VAR2A,4,1)-50)*2,3,1);

VAR2C:=(INDEXC-LLV(INDEXL,8))/(HHV(INDEXH,8)-LLV(INDEXL,8))*100;

VAR2D:=SMA(VAR2C,4,1);

VAR2E:=SMA(VAR2D,3,1);

VAR2F:=(HHV(HIGH,13)-CLOSE)/CLOSE*100;

VARE2:=REF(LOW,1)*0.9;

VARF2:=LOW*0.9;

VAR210:=(VARF2*VOL+VARE2*(CAPITAL-VOL))/CAPITAL;

VAR211:=EMA(VAR210,5);

VAR212:=CLOSE-REF(CLOSE,1);

VAR213:=MAX(VAR212,0);

VAR214:=ABS(VAR212);

VAR215:=SMA(VAR213,5,1)/SMA(VAR214,5,1)*100;

VAR216:=SMA(VAR213,8,1)/SMA(VAR214,8,1)*100;

VAR217:=BARSCOUNT(21);

VAR218:=SMA(MAX(VAR212,0),6,1)/SMA(ABS(VAR212),6,1)*100;

VAR219:=(-200)*(HHV(HIGH,55)-CLOSE)/(HHV(HIGH,55)-LLV(LOW,55))+100;

导弹:=CROSS(VAR218<=25 AND VAR219<-95 AND VAR2F>20 AND VAR2B<-30 AND VAR2E<30 AND VAR211-CLOSE>=-0.25 AND VAR215<22 AND VAR216<28 AND VAR217>50,0.5) AND COUNT(VAR218<=25 AND VAR219<-95 AND VAR2F>20 AND VAR2B<-30 AND VAR2E<30 AND VAR211-CLOSE>=-0.25 AND VAR215<22 AND VAR216<28 AND VAR217>50=1,10)=1;

JS2:DRAWICON(导弹,LOW-0.4,26);

JS3:DRAWTEXT(导弹,LOW-0.6,’金石买入’),COLORYELLOW;

    © 版权声明
    THE END
    喜欢就支持一下吧
    点赞8赞赏 分享
    评论 抢沙发
    头像
    欢迎您留下宝贵的见解!
    提交
    头像

    昵称

    取消
    昵称表情代码图片

      暂无评论内容