2023【寻龙诀AI量化系统】套装指标主副选,源码分享给有缘人

寻龙诀量化指标核心逻辑:

寻龙诀指标逻辑是一款实时监测游资和主力资金动向的量化系统,紧跟时代的发展,运用先进的AI量化模型、大量的数字化数据组成,通过总结市场上几十年的k线形态以及主力各种建仓、洗盘、吸筹、拉升、出货的手法来辅助投资者把握市场的节奏!

寻龙诀量化指标使用说明:

1、潜龙勿用和放量:主力建仓信号,主要表现是底部伴随着成交量突然放大,此位置不需要做重点关注,因为接下来可能会面临着主力洗盘。

2、黑夜之眼信号:是主力资金吸筹结束,此时大部分筹码已经在主力手里,处于黎明前的黑夜阶段

3、飞龙在天信号:确认主力拉升信号,是大趋势行情的启动信号,主要伴随着股价突破,代表上车位置。

4、见龙在田信号:主力资金潜伏,在逐渐小幅拉升迹象,伺机而动。

5、主图亢龙有悔信号:主力出货,可以下车。


三大进场信号

1、黑夜之眼:主力建底仓信号(上车机会)

2、见龙在田:主力加仓信号(加仓机会)

3、飞龙在天:主力做主升信号(强势涨停板)


选股入场时机:

1、尽量每天下午2:30以后用选股器选股

2、等待数据稳定,这种信号才稳定。

3、或者直接收盘以后选,第二天再考虑进场也可以。


寻龙诀精选口诀

1、指数低位启动,或者上行趋势良好,积极参与;如果指数处于高位,从高位往下走,呈现下跌趋势,下跌趋势的反抽行情,尽量回避,行情难持续。

2、符合当日主线行情的优先考虑。

3、同一个概念或者行业,出现两个以上企业的时候,这种也叫出现共振效应,也做优先考虑。

4、中小市值,基本面优秀、业绩稳定的优先考虑。

5、在精选过程中,对于指数高低,或者当日主线行情的判断,寻找热点板块!

2023【寻龙诀AI量化系统】套装指标主副选,源码分享给有缘人

2023【寻龙诀AI量化系统】套装指标主副选,源码分享给有缘人

2023【寻龙诀AI量化系统】套装指标主副选,源码分享给有缘人

2023【寻龙诀AI量化系统】套装指标主副选,源码分享给有缘人

2023【寻龙诀AI量化系统】套装指标主副选,源码分享给有缘人

{亢龙有悔主图}


DRAWGBK(CLOSE>1,RGB(0,0,0),RGB(86,219,254),0,0,0);

SR1:=REF(HIGH,10)=HHV(HIGH,2*10+1);

SR2:=FILTER(SR1,10);

SR3:=BACKSET(SR2,10+1);

HDD:=FILTER(SR3,10);

前高高:=REF(H,BARSLAST(HDD));

倍量量:=VOL/REF(VOL,1)>=1.9;

突破前高高:=CROSS(C,前高高);

强庄:=倍量量 AND 突破前高高;

DRAWGBK(C>1,RGB(0,0,0),RGB(1,1,1),1,0,0);

DRAWKLINE(H,O,L,C);

BK:=IF(INBLOCK(‘科创板’),0.2,IF(INBLOCK(‘创业板’),0.2 ,IF(INBLOCK(‘ST板块’),0.05,0.1)));

ZTBTJ1:=C>=MAX((INTPART(REF(C,1)*1.1*100)/100),ZTPRICE(REF(C,1),BK));

ZTBTJ2:=C>=(INTPART(REF(C,1)*1.05*100)/100);分析家公式网:DRAWNULL,COLOR444444;

涨停提示:=IF(NAMELIKE(‘ST’) OR NAMELIKE(‘*’) OR NAMELIKE(‘SS’) OR NAMELIKE(‘S’),ZTBTJ2,ZTBTJ1);

STICKLINE(IF(CODELIKE(‘999’) OR CODELIKE(‘399’) OR CODELIKE(‘880’) OR NAMELIKE(‘超大盘’),DRAWNULL,涨停提示 AND PERIOD=5 AND O!=H),C,O,3,0),COLORYELLOW;

STICKLINE(IF(CODELIKE(‘999’) OR CODELIKE(‘399’) OR CODELIKE(‘880’) OR NAMELIKE(‘超大盘’),DRAWNULL,涨停提示 AND PERIOD=5 AND O!=H),C,O,3,0),COLORYELLOW;

MID:=(3*CLOSE+LOW+OPEN+HIGH)/6;

主力:=(20*MID+19*REF(MID,1)+18*REF(MID,2)+17*REF(MID,3)+16*REF(MID,4)+15*REF(MID,5)+14*REF(MID,6)+13*REF(MID,7)+12*REF(MID,8)+11*REF(MID,9)+10*REF(MID,10)+9*REF(MID,11)+8*REF(MID,12)+7*REF(MID,13)+6*REF(MID,14)+5*REF(MID,15)+4*REF(MID,16)+3*REF(MID,17)+2*REF(MID,18)+REF(MID,20))/210,COLORRED;

A:=REF(HIGH,9)=HHV(HIGH,2*9+1);

B:=FILTER(A,9);

AB:=BACKSET(B,9+1);

HD:=FILTER(AB,9);

前高:=REF(H,BARSLAST(HD));

倍量:=VOL/REF(VOL,1)>=1.1;

突破前高:=CROSS(C,前高);

XG:=倍量AND突破前高;

YX:=DRAWLINE(XG,L,XG,L,1);

重点:=XG AND 强庄;

STICKLINE(XG,OPEN,CLOSE,0.2,0),COLOR00FFFF;

DRAWTEXT(XG,L*0.98,”),COLORYELLOW;

DRAWICON(XG,L*1,9);

DRAWICON(重点 AND COUNT(重点,10)>=2,L*0.98,9);

DRAWICON(重点 AND COUNT(重点,10)>=2,L*0.96,9);

DRAWICON(重点 AND COUNT(重点,10)>=2,L*0.94,9);

MID1:=MA(C,15)*1.005;

VART1:=POW((C-MID1),2);

VART2:=MA(VART1,15);

VART3:=SQRT(VART2);

UPPER:=MID1+2*VART3;

LOWER:=MID1-2*VART3;

启明线:=REF(MID1,1),COLORFFFFFF;

揽月线:=REF(UPPER,1),COLOR00FFFF;

U:=IF(启明线>REF(启明线,1),启明线,DRAWNULL),COLORRED,LINETHICK1;

D1:=IF(启明线< REF(启明线,1),启明线,DRAWNULL),COLORGREEN,LINETHICK1;

DRAWICON(CLOSE>揽月线,LOW,9);

DRAWICON(REF(C,1)>揽月线 AND CLOSE< 揽月线,HIGH,2);

LC:=REF(CLOSE,2);

RSI:=((SMA(MAX((CLOSE – LC),0),3,1) / SMA(ABS((CLOSE – LC)),3,1)) * 80);

FF:=EMA(CLOSE,3);

MA15:=EMA(CLOSE,21);

DRAWTEXT(CROSS(68,RSI),(HIGH * 1.02),’亢龙有悔’),COLORYELLOW;


寻龙诀副图


MMM:=1;

SVOL:=INTPART(SUM(V,0)/CAPITAL);

TJ0:=SVOL>REF(SVOL,1) OR BARSSINCE(CLOSE)=0;

SF1:=BARSLAST(TJ0)+1;

TJJ2:=SF1< REF(SF1,1);

S2:=IF(TJJ2,REF(SF1,1)+1,SF1);

S3:=SUM(TJJ2,0);

ZK1:=”KD.K#WEEK”(9,3,3);

ZD2:=”KD.D#WEEK”(9,3,3);

ZF1:=”MACD.DIF#WEEK”(5,34,5);

ZA2:=”MACD.DEA#WEEK”(5,34,5);

换手:=V/CAPITAL*100,LINETHICK0;

JCD:=CROSS(ZK1,ZD2) AND REF(ZD2,1)< 60;

波段低点:=EXIST(JCD,MMM),COLORYELLOW,NODRAW;

STICKLINE(IF(波段低点,20,0),-5,0,2,0),COLORYELLOW;

VAR1A:=DMA(AMOUNT/VOL/100,VOL/CAPITAL);

VAR4AA:=CLOSE/(REF(CLOSE,1))>1.05 AND (HIGH/CLOSE< 1.01);

游资进场:=(FILTER(VAR4AA>0,34)AND DYNAINFO(4)>0)*8,COLORYELLOW;

A100:=5;

STICKLINE(游资进场,10,18,2.4,0),COLORWHITE;

DRAWTEXT(游资进场,18,’▲柚子进场’),COLORYELLOW;

LS:=C/REF(C,1)>1.048 AND C=H AND BETWEEN(FORCAST(V,4),0.2*FORCAST(V,6),2.1*FORCAST(V,6));

拉升:=FILTER(LS,14);

STICKLINE(拉升,0,16,1,0),COLORBROWN;

DRAWICON(拉升,16.2,9);

A1J:=ABS(((3.48*CLOSE+HIGH+LOW)/4-EMA(CLOSE,10))/EMA(CLOSE,10));

A2J:=DMA(((2.15*CLOSE+LOW+HIGH)/4),A1J);

金线王:=EMA(A2J,5)*1;

金线王2:=EMA(A2J,200)*1.118;

条件:=(C-REF(C,1))/REF(C,1)*100>8;

金K线:=CROSS(C,金线王) AND 条件;

RRFJ:=金K线,STICK;

STICKLINE(IF(RRFJ,20,0),+10,0,2,0),COLORYELLOW;

VAR11:=REF(LOW,1);

VAR2H:=(SMA(ABS(LOW-VAR11),13,1))/(SMA(MAX(LOW-VAR11,0),13,1))*4;

VAR3H:=EMA(VAR2H,13);

VAR4H:=LLV(LOW,34);

VAR5H:=EMA(IF(LOW<=VAR4H,VAR3H,0),3);

VAR6H:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1) +2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);

VAR7H:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1) +2*SMA(SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);

VAR8H:=VAR6H< REF(VAR7H,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);

T1R:=MA(MA(MA(EMA(CLOSE,1),2),2),2);

TR1:=EMA((T1R-REF(T1R,1))/REF(T1R,1),1)*1000,COLORFF00FF,NODRAW;

净:=MA(TR1,11);

流:=EMA(净,11);

主力动向:=EMA(净+流,1)-MA(净-流,2),COLORFF00FF,NODRAW;

MA1:=MA(主力动向,13),COLORFF00FF,NODRAW;

MA3:=EMA(MA1,2);

LC:=REF(CLOSE,1);

RSI:=((SMA(MAX((CLOSE – LC),0),3,1) / SMA(ABS((CLOSE – LC)),3,1)) * 100);

VWR5:=C>MAX(REF(C,1),REF(O,1)) AND C/MAX(REF(C,1),REF(O,1))>1.02;

VWR6:=REF(VWR5,1) AND VWR5=0;

DOWNQK1:=RSI>76;

VWR8:=VWR6 AND DOWNQK1;

VWR9:FILTER(VWR8,10);

VA:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL);

OBV6:=SUM(IF(CLOSE=REF(CLOSE,1),0,VA),0);

OBV7:=EMA(OBV6,3)-MA(OBV6,9);

OBV8:=EMA(IF(OBV7>0,OBV7,0),3);

MAC:=MA(C,3);

RC:=DYNAINFO(3);

AP:=VOL*C;

BP:=SUM(AP,1)/SUM(VOL,1);

B1:=EMA(BP,17);

资金:=(BP-B1)*100/BP;

DIF:=EMA(资金,12)-EMA(资金,26),COLORGREEN;

DEA:=EMA(DIF,9),COLORCYAN;

MACD:=(DIF-DEA)*2,;

STICKLINE(OBV8>REF(OBV8,1) AND MAC>REF(MAC,1),0,MACD,3,0),COLORRED;

吸:=XLPL.NOTEXT吸,COLORMAGENTA,CIRCLEDOT,LINETHICK3;

拉:=XLPL.NOTEXT拉,COLORRED,CIRCLEDOT,LINETHICK3;

派:=XLPL.NOTEXT派,COLORGREEN,CIRCLEDOT,LINETHICK3;

落:=XLPL.NOTEXT落,COLORWHITE,CIRCLEDOT,LINETHICK3;

STICKLINE(吸,0,MACD,4,0),COLORYELLOW;

STICKLINE(拉,0,MACD,4,0),COLORMAGENTA;

DIFZ:=EMA(CLOSE,12)-EMA(CLOSE,26);

DEAZ:=EMA(DIFZ,9);

MACD6:=(DIFZ-DEAZ)*2,COLORSTICK;

主力进驻:=COUNT(MACD6< 0,10)=10,COLORRED,NODRAW;

VA1:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL);

OBV1:=SUM(IF(CLOSE=REF(CLOSE,1),0,VA1),0);

OBV2:=EMA(OBV1,3)-MA(OBV1,9);

OBV3:=EMA(IF(OBV2>0,OBV2,0),3);

MAC3:=MA(C,3);

RCC:=DYNAINFO(3);

AP3:=VOL*C;

BP3:=SUM(AP3,1)/SUM(VOL,1);

B13:=EMA(BP3,17);

资金1:=(BP3-B13)*100/BP3;

DIF3:=EMA(资金1,12)-EMA(资金1,26),COLORGREEN;

DEA3:=EMA(DIF3,9),COLORCYAN;

MACD1:=(DIF3-DEA3)*2,;

STICKLINE(OBV3>REF(OBV3,1) AND MAC3>REF(MAC3,1),0,MACD,2,0),COLORMAGENTA;

持币1:STICKLINE((SAR(10,2,20)>=H),MACD1,0,1.5,0),COLORGREEN;

持股1:STICKLINE((SAR(10,2,20)<=L),0,MACD1,1.5,0),COLORCYAN;

吸1:=XLPL.NOTEXT吸,COLORMAGENTA,CIRCLEDOT,LINETHICK3;

拉1:=XLPL.NOTEXT拉,COLORMAGENTA,CIRCLEDOT,LINETHICK3;

派1:=XLPL.NOTEXT派,COLORGREEN,CIRCLEDOT,LINETHICK3;

落1:=XLPL.NOTEXT落,COLORWHITE,CIRCLEDOT,LINETHICK3;

STICKLINE(吸1,0,MACD1,2,0),COLORMAGENTA;

STICKLINE(拉1,0,MACD1,2,0),COLORMAGENTA;

STICKLINE(派1,0,MACD1,3,0),COLORGREEN;

STICKLINE(落1,0,MACD1,2,0),COLORBLUE;

LCF:=REF(CLOSE,1);

RSI5:=((SMA(MAX((CLOSE – LCF),0),5,1) / SMA(ABS((CLOSE – LCF)),5,1)) * 100);

TR1F:=SUM(MAX(MAX((HIGH – LOW),ABS((HIGH – REF(CLOSE,1)))),ABS((LOW – REF(CLOSE,1)))),10);

HD:=(HIGH – REF(HIGH,1));

LD:=(REF(LOW,1) – LOW);

DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10);

DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);

PDI:=((DMP * 100) / TR1F);

MDI:=((DMM * 100) / TR1F);

ADX:=MA(((ABS((MDI – PDI)) / (MDI + PDI)) * 100),5);

AV:=(RSI5 + ADX);

DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);

WR10:=((100 * (HHV(HIGH,60) – CLOSE)) / (HHV(HIGH,60) – LLV(LOW,60)));

NEWVOL:=(RSI5 – WR10);

金坑买入:=(AV + NEWVOL);

买入选股:=IF(CROSS(金坑买入,0),1,0),STICK,COLORRED;

VAR1Z:=SMA(买入选股,8,1);

VAR2Z:=SMA(VAR1Z,8,1),COLOR0000FF;

VAR3Z:=SMA(VAR2Z,10,1),COLOR00FFFF;

金坑吸筹:=IF(CROSS(VAR2Z,VAR3Z) AND (VAR2Z< 40),5,0* 10000),COLOR0000FF,LINETHICK1;

MACD2:=(DIF-DEA)*2,;

STICKLINE(OBV3>REF(OBV3,1) AND MAC3>REF(MAC3,1),0,MACD2,3,0),COLORYELLOW;

持币2:STICKLINE((SAR(10,2,20)>=H),MACD2,0,1.5,0),COLORGREEN;

持股2:STICKLINE((SAR(10,2,20)<=L),0,MACD2,1.5,0),COLORCYAN;

吸2:=XLPL.NOTEXT吸,COLORMAGENTA,CIRCLEDOT,LINETHICK3;

拉2:=XLPL.NOTEXT拉,COLORMAGENTA,CIRCLEDOT,LINETHICK3;

派2:=XLPL.NOTEXT派,COLORGREEN,CIRCLEDOT,LINETHICK3;

落2:=XLPL.NOTEXT落,COLORWHITE,CIRCLEDOT,LINETHICK3;

STICKLINE(吸2,0,MACD2,1.2,0),COLORMAGENTA;

STICKLINE(拉2,0,MACD2,1.7,0),COLORMAGENTA;

STICKLINE(派2,0,MACD2,2,0),COLORBLUE;

STICKLINE(落2,0,MACD2,1,1),COLORGRAY;

VAR1:=EMA(EMA(CLOSE,9),9);

控盘:=(VAR1-REF(VAR1,1))/REF(VAR1,1)*350;

A10:=CROSS(控盘,0);

无庄控盘:=IF(控盘< 0,控盘,0),COLORWHITE,NODRAW;

STICKLINE(控盘>REF(控盘,1) AND 控盘>0,控盘,0,1,0),COLORRED;

有庄控盘:IF(控盘>REF(控盘,1) AND 控盘>0,控盘,0),COLORRED,NODRAW;

VAR2F:=100*WINNER(CLOSE*0.95);

STICKLINE(控盘< REF(控盘,1) AND 控盘>0,控盘,0,1,0),COLOR00FF00;

DRAWTEXT(游资进场,18,’ 游资’),COLORMAGENTA;

DRAWTEXT(拉升,16,’  ▲飞龙在天’),COLORYELLOW;

DRAWTEXT(RRFJ,10.5,’  ▲见龙再田’),COLORYELLOW;

DRAWTEXT(VAR8H AND COUNT(VAR8H,18)=1,6,”),COLORWHITE;

DRAWTEXT(波段低点,-6,’ ▲黑夜之眼’),COLORYELLOW;

AA:=VOL;

BB:=REF(MA(VOL,5),1);

CC:=AA/BB;

A1:=CC>=0.001 AND CC< 0.5;

A2:=CC>=0.5 AND CC< 0.8;

A3:=CC>=0.8 AND CC< 1.5;

A4:=CC>=1.5 AND CC< 2.3;

A5:=CC>=2.5 AND CC< 5.0;

A6:=CC>=5.0 AND CC< 10.0;

A7:=CC>=10.0 AND CC< 20.0;

关注线:1.5,COLORFFFFFF,LINETHICK1;

温和放量:=A4,STICK,COLOR00CCFF;

STICKLINE(A5,0,CC,2,0),COLORBLUE;

明显放量:A5,STICK,COLORLIBLUE;

DRAWTEXT(明显放量,3.5,’ ▲潜龙勿用’),COLORWHITE;

XG:STICKLINE(A6,0,CC,1.2,0),COLORBLUE;

DRAWTEXT(XG,7,’ ▲放量’),COLORCYAN;

放量线:2.5,COLORRED,LINETHICK2;

今日量比:VOL/REF(MA(VOL,5),1),COLORFFFFFF,NODRAW;

DIF1:=EMA(DCLOSE,12)-EMA(DCLOSE,26);

DEA1:=EMA(DIF1,9);

AAA1:=(DIF1-DEA1)*2*60;

XP1:=10;

XP2:=AAA1-REF(AAA1,1);

DB:=CROSS(XP2,XP1),COLORWHITE,LINETHICK2;



{寻龙诀选股器}



A:=REF(HIGH,9)=HHV(HIGH,2*9+1);

B:=FILTER(A,9);

AB:=BACKSET(B,9+1);

HD:=FILTER(AB,9);

前高:=REF(H,BARSLAST(HD));

倍量:=VOL/REF(VOL,1)>=1.1;

突破前高:=CROSS(C,前高);

X_1:=MA(CLOSE,10);

X_2:=MA(CLOSE,55);

X_3:=(REF(CLOSE,3)-CLOSE)/REF(CLOSE,3)*100>5;

X_4:=FILTER(X_3,10);

X_5:=BARSLAST(X_4);

X_6:=REF(HIGH,X_5+2);

X_7:=REF(HIGH,X_5+1);

X_8:=REF(HIGH,X_5);

X_9:=MAX(X_6,X_7);

X_10:=MAX(X_9,X_8);

X_11:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>5;

X_12:=X_5< 150;

X_13:=(OPEN-X_10)/X_10*100< 30;

X_14:=(CLOSE-LLV(LOW,X_5))/LLV(LOW,X_5)*100< 50;

X_15:=(CLOSE-REF(OPEN,5))/REF(OPEN,5)*100< 30;

X_16:=VOL/MA(VOL,5)< 3.5;

X_17:=(CLOSE-REF(CLOSE,89))/REF(CLOSE,89)*100< 80;

X_18:=X_11 AND X_12 AND X_13 AND X_14 AND X_15 AND X_16 AND X_17;

X_19:=FILTER(X_18,15);

X_20:=(CLOSE-X_2)/X_2< 0.1;

X_21:=(CLOSE-X_1)/X_1< 0.3;

X_22:=(X_20=1 AND X_21=1)*0.2;

X_23:=(X_22=0 AND REF(X_22,1)=0.2 AND REF(COUNT(X_22=0.2,10)=10,1)=1)*(-0.1);

X_24:=X_23=(-0.1);

X_25:=X_19 OR X_24;

X_26:=DYNAINFO(7)/REF(CLOSE,1)>1.05 AND DYNAINFO(7)/OPEN>1.05;

X_27:=VOL/REF(VOL,1)>1.2 AND CLOSE>OPEN OR (LOW>REF(HIGH,1) AND OPEN>CLOSE AND VOL/REF(VOL,1)>1.2);

X_28:=IF(CODELIKE(3) OR (CODELIKE(4) AND DATE>=1200824),CLOSE>=ZTPRICE(REF(CLOSE,1),0.2) AND CLOSE=HIGH,CLOSE>=ZTPRICE(REF(CLOSE,1),0.1) AND CLOSE=HIGH);

选股:X_25 AND X_26 AND X_27 AND X_28 AND REF(NOT(X_28),1) AND 倍量 AND 突破前高;

站在巨人的肩膀上,通过进走势规律不断摸索,不断优化进取所得精华源码,指标全以电脑编辑郑重提示:现在公众号的推送规则改变了,有些读者反映收不到文章推送的情况,为防止大家看不到重要的文章,大家可以点击左上方“通达信指标爱好者”,再点击右上角的“…”,随后点“设为星标★”就可以及时收到文章的推送了,创作不易请收藏点赞转发。。。你的支持是我最大的动力。。。


    © 版权声明
    THE END
    喜欢就支持一下吧
    点赞6赞赏 分享
    评论 抢沙发
    头像
    欢迎您留下宝贵的见解!
    提交
    头像

    昵称

    取消
    昵称表情代码图片

      暂无评论内容