全能中短线,对macd添加了背离说明和二次金叉买入标注

这里发的指标均是通达信电脑版软件指标公式,手机软件有的可能不通用,但大部分通用,具体没测试过复制指标源码,新建粘贴到软件保存即可,不懂的公众号菜单看指标教程或回复关键字:指标帮助  。

指标说明:

副图指标,对macd红绿柱做了修改,添加了背离说明和二次金叉买入标注,黑马提示和短线吸筹标注柱。

指标例图:

全能中短线,对macd添加了背离说明和二次金叉买入标注

全能中短线,对macd添加了背离说明和二次金叉买入标注

 

指标源码:

TJ1:=REF(C,3)/REF(C,2)>1.045 AND REF(C,2)<REF(O,2);
TJ2:=BETWEEN(REF(C,1)/REF(O,1),1.005,0.995) AND REF(H,1)/REF(O,1)>1.025 AND REF(C,1)/REF(L,1)>1.025 AND REF(O,1)<REF(C,2);
星停:C/REF(C,1)>1.09 AND C=H AND TJ1 AND TJ2;
T:=IF((BARSCOUNT(C) > 7),(100)*((MA(C,7))/(LLV(MA(C,7),7)) – 1),1);
N:=IF((T > 0.35),6,65);
W:=((-((100)*(HHV(H,N) – C))/(HHV(HIGH,N) – LLV(L,N))));
RV:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
RG:=(CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100;
J0:=(HIGH+LOW)/2;
QJ:=EMA(J0,3);
J1:=IF(CLOSE>QJ,VOL,0);
J2:=IF(CLOSE<QJ,VOL,0);
BB:=MA(SUM(J1-J2,22),3);
累加:=21*BB+20*REF(BB,1)+19*REF(BB,2)+18*REF(BB,3)+17*REF(BB,4)+16*REF(BB,5)+15*REF(BB,6)+14*REF(BB,7)+13*REF(BB,8)+12*REF(BB,9)+11*REF(BB,10)+10*REF(BB,11)+9*REF(BB,12)+8*REF(BB,13)+7*REF(BB,14)+6*REF(BB,15)+5*REF(BB,16)+4*REF(BB,17)+3*REF
(BB,18)+2*REF(BB,19)+REF(BB,20);
WMA1:=累加/(21+1)/21*2;
CC:=WMA1;
VAR3:=(BB-CC);VAR4:=SMA(RV,3,1);
VAR5:=SMA(VAR4,3,1);
KK:=EMA(SMA(RG,3,1),2);
DD:=SMA(KK,3,1);
追停:CROSS(W,-2) AND CROSS(VAR4,VAR5) AND CROSS(KK,DD);
 
TJ11:=REF(CROSS(MA(C,5),C),1) AND CROSS(C,MA(C,5));
TJ21:=REF(CROSS(MA(C,10),C),1) AND CROSS(C,MA(C,10));
TJ31:=REF(CROSS(MA(C,20),C),1) AND CROSS(C,MA(C,20));
TJ4:=TJ11 OR TJ21 OR TJ31;
 
极停:REF(C,2)/REF(C,1)>=1.045 AND REF(C,1)<REF(O,1) AND C/REF(C,1)>1.09 AND C=H AND TJ4;
个股:=EMA(100*(C-LLV(LOW,34))/(HHV(H,34)-LLV(LOW,34)),3),COLOR1010FF;
黑马:IF(CROSS(个股,9),1,0)*0.5,STICK,LINETHICK6,COLORYELLOW;
DRAWTEXT(CROSS(个股,9),1,’黑马!’)*0.5,COLOR00FF00;
DIFF: EMA(CLOSE,12) – EMA(CLOSE,26);
DEA: EMA(DIFF,9);
MACD=2*(DIFF-DEA);
ZERO:=0;
GJ:=MAX(C,O);
STICKLINE(MACD>0 AND MACD>=REF(MACD,1),0,MACD,1.3,0),COLOR0000FF;
STICKLINE(MACD>0 AND MACD<REF(MACD,1),0,MACD,1.3,0),COLORFFFF00;
STICKLINE(MACD<0 AND MACD>=REF(MACD,1),0,MACD,1.3,0),COLORFF00FF;
STICKLINE(MACD<0 AND MACD<REF(MACD,1),0,MACD,1.3,0),COLOR00FF00;
A0:=DIFF<0 AND DEA<0;
A11:=A0>REF(A0,1);
A3:=BARSLAST(A11);
A4:=COUNT(DEA>0 AND DIFF >0,A3)=0;
A5:=CROSS(DIFF ,DEA);
A6:=BARSLAST(A5);
A7:=REF(A6,A6+1)+A6;
A8:=(DIFF+DEA)/2;
A9:=(HIGH+LOW)/2;
A10:=A5 AND A7<A3 AND A4 AND A8>REF(A8,A7) AND A9<REF(A9,A7) AND MACD>0;
DRAWTEXT(A10,DIFF*0.95,’★金叉买入’),COLORYELLOW;
 
AA:=(O+H+L+C)/4;
A1:=HHV(AA,15);
A2:=LLV(AA,15);
A33:=A1-A2;
A43:=EMA((AA-A2)/A33,2)*9;
RSV:= (HHV(HIGH,3)-CLOSE)/(HHV(HIGH,3)-LLV(LOW,3))*10;
空:=SMA(RSV,2,1)/5;
多:=A43;
抄底白:0,COLORWHITE;
STICKLINE(空>1.3 AND 多<0.3 AND C*0.02<(EMA(C,5)-C),0,ABS(SMA(MAX(MACD,0),5,1)-ABS(MACD))*0.5,3,0),COLORWHITE;

    © 版权声明
    THE END
    喜欢就支持一下吧
    点赞15赞赏 分享
    评论 抢沙发
    头像
    欢迎您留下宝贵的见解!
    提交
    头像

    昵称

    取消
    昵称表情代码图片

      暂无评论内容