红色风暴主图+抄底追击通达信指标

该指标整合均线粘合、能量潮、OBV解析、多空量能等多种助涨要素,配以原创风暴均线,个股走势、强弱形态一看便知。 指标含有一点未来函数,但不影响其使用效果,一试便知,绝无虚言

抄底追击 源码中含小部分WINNER函数 火箭发射图案是抄底提示,34号图标是追击买入提示。

红色风暴主图+抄底追击通达信指标

红色风暴主图+抄底追击通达信指标

红色风暴主图+抄底追击通达信指标

红色风暴主图+抄底追击通达信指标

红色风暴主图+抄底追击通达信指标


主图源码


X_1:=2;

X_2:=BARSLAST(CURRBARSCOUNT=100);

X_3:=CONST(IF(ISLASTBAR=1,LLV(LOW,X_2),0));

X_4:=IF(AMOUNT/CLOSE/(HHV(AMOUNT,20)/HHV(CLOSE,20))*100>100,100,AMOUNT/CLOSE/(HHV(AMOUNT,20)/HHV(CLOSE,20))*100);

AA10:MA(CLOSE,0),COLORRED;

AA12:MA(CLOSE,0),COLORRED;

X_5:=ATAN(AA10-REF(AA10,1))*3.1416*10;

X_6:=ATAN(AA12-REF(AA12,1))*3.1416*10;

X_7:=MA(CLOSE,13);

X_8:=(CLOSE+LOW+HIGH)/3;

X_9:=ATAN(EMA(X_8,13)-REF(EMA(X_8,13),1))*3.1416*10;

X_10:=EMA(CLOSE,8);

DRAWBAND(IF(CURRBARSCOUNT<=100,X_3+MACD.DIF*1.5,DRAWNULL),RGB(230,12,12),X_3,RGB(10,30,230));

DRAWBAND(IF(CURRBARSCOUNT<=100,X_3+MACD.DIF*1.5,DRAWNULL),RGB(230,30,12),X_3,RGB(10,200,30));

IF(CURRBARSCOUNT<100,X_3+MACD.DIF*1.5,DRAWNULL),COLORYELLOW;

X_11:=EMA(EMA(CLOSE,2),2);

AZ1:EMA(HHV(X_11,1),2),COLORWHITE;

AZ2:EMA(HHV(AZ1,X_1),1),COLORFF99FF;

AZ3:EMA(HHV(AZ2,X_1),2),COLORFF77FF;

AZ4:EMA(HHV(AZ3,X_1),3),COLORFF55FF;

AZ5:EMA(HHV(AZ4,X_1),4),COLORFF33FF;

AZ6:EMA(HHV(AZ5,X_1),5),COLORFF11FF;

AZ7:EMA(HHV(AZ6,X_1),6),COLORMAGENTA;

STICKLINE(OPEN>=CLOSE,HIGH,LOW,0,0),COLORCYAN;

STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,3,0),COLORCYAN;

STICKLINE(CLOSE>OPEN,LOW,HIGH,0,0),COLORRED;

STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3,1),COLORRED;

IF(AZ1<REF(AZ1,1),AZ1,DRAWNULL),COLORDD1100;

IF(AZ2<REF(AZ2,1),AZ2,DRAWNULL),COLORDD2200;

IF(AZ3<REF(AZ3,1),AZ3,DRAWNULL),COLORDD3300;

IF(AZ4<REF(AZ4,1),AZ4,DRAWNULL),COLORDD4400;

IF(AZ5<REF(AZ5,1),AZ5,DRAWNULL),COLORDD5500;

IF(AZ6<REF(AZ6,1),AZ6,DRAWNULL),COLORDD6600;

IF(AZ7<REF(AZ7,1),AZ7,DRAWNULL),COLORDD7700;

WWW70822COM:DRAWNULL,COLORRED;

X_12:=EMA(CLOSE,5);

X_13:=EMA(CLOSE,13);

X_14:=EMA(CLOSE,34);

X_15:=EMA(CLOSE,55);

X_16:=EMA(CLOSE,89);

X_17:=MAX(MAX(MAX(X_12,X_13),X_14),X_15)/MIN(MIN(MIN(X_12,X_13),X_14),X_15)<=1.01 AND X_13>REF(X_13,1) AND X_14>REF(X_14,1) AND X_15>REF(X_15,1);

X_18:=MAX(MAX(X_12,X_13),X_14)/MIN(MIN(X_12,X_13),X_14)<=1.01 AND X_12>REF(X_12,1) AND X_13>REF(X_13,1) AND X_14>REF(X_14,1);

X_19:=MAX(MAX(X_12,X_13),X_16)/MIN(MIN(X_12,X_13),X_16)<=1.01 AND X_13>REF(X_13,1);

X_20:=MAX(MAX(X_13,X_14),X_15)/MIN(MIN(X_13,X_14),X_15)<=1.01 AND X_13>REF(X_13,1);

X_21:=X_17 OR X_18 OR X_19 OR X_20;

STICKLINE(X_21,LLV(CLOSE,5)*0.998,LLV(CLOSE,5)*0.995,50,0),COLOR33CCDD;

X_22:=MA(CLOSE,60)>REF(MA(CLOSE,60),1) AND CLOSE>MA(CLOSE,60) AND AZ1>REF(AZ1,1) AND AZ2>REF(AZ2,1) AND AZ3>REF(AZ3,1) AND AZ4>REF(AZ4,1) AND AZ5>REF(AZ5,1) AND AZ6>REF(AZ6,1) AND AZ7>REF(AZ7,1);

X_23:=30;

X_24:=10;

X_25:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL);

X_26:=SUM(IF(CLOSE=REF(CLOSE,1),0,X_25),0);

X_27:=MA(OBV,X_23);

X_28:=REF(X_26,X_24)=HHV(X_26,2*X_24+1);

X_29:=FILTER(X_28,X_24);

X_30:=BACKSET(X_29,X_24+1);

X_31:=FILTER(X_30,X_24);

X_32:=REF(OBV,BARSLAST(X_31));

X_33:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));

X_34:=(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;

X_35:=IF(CLOSE>OPEN,X_33*(HIGH-LOW),IF(CLOSE<OPEN,X_33*(HIGH-OPEN+(CLOSE-LOW)),VOL/2));

X_36:=SMA(X_34,3,1);

X_37:=SMA(X_36,3,1);

X_38:=3*X_36-2*X_37;

X_39:=EMA(X_38,6);

X_40:=100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34));

X_41:=IF(CLOSE>OPEN,X_28*(HIGH-CLOSE+(OPEN-LOW)),IF(CLOSE<OPEN,X_28*(HIGH-LOW),VOL/2));

X_42:=SMA(X_40,3,1);

X_43:=SMA(X_42,3,1);

X_44:=3*X_42-2*X_43;

X_45:=EMA(X_44,6);

X_46:=IF(CROSS(X_39,X_45),100,0);

DRAWICON(X_46=100,LOW*0.975,25);

DRAWICON(CROSS(OBV,X_32),LOW*0.985,27);

DRAWICON(FILTER(X_9>1 AND EMA(X_8,13)>REF(EMA(X_8,8),1),10),LOW*0.975,23);

IF(X_22,MA(CLOSE,60),DRAWNULL),CIRCLEDOT,COLORYELLOW;

DRAWTEXT_FIX(ISLASTBAR,0,0,0,2),COLORYELLOW;

JJ:MA(CLOSE,60),COLORRED,LINETHICK2;

X_47:=BACKSET(JJ<REF(JJ,1),2);

IF(X_47,JJ,DRAWNULL),COLORA53412,LINETHICK2;

IF(JJ<REF(JJ,1),JJ,DRAWNULL),COLORCYAN;

STICKLINE(OPEN>CLOSE,CLOSE,OPEN,3,0),COLORFF7700;

STICKLINE(OPEN>CLOSE,CLOSE,OPEN,2.2,0),COLORFF9900;

STICKLINE(OPEN>CLOSE,CLOSE,OPEN,1.5,0),COLORFFBB00;

STICKLINE(OPEN>CLOSE,CLOSE,OPEN,0.5,0),COLORCYAN;

STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3,0),COLOR000099;

STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2.2,0),COLOR0000CC;

STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1.5,0),COLORRED;

STICKLINE(CLOSE>OPEN,CLOSE,OPEN,0.5,0),COLORCC66FF;

STICKLINE(CLOSE=OPEN,CLOSE,OPEN,3,0),COLORWHITE;

STICKLINE(CLOSE=OPEN,CLOSE,OPEN,2.2,0),COLORWHITE;

STICKLINE(CLOSE=OPEN,CLOSE,OPEN,1.5,0),COLORWHITE;

STICKLINE(CLOSE=OPEN,CLOSE,OPEN,0.5,0),COLORWHITE;

X_48:=CLOSE/REF(CLOSE,1)>=1.05 AND NOT(CLOSE>=INTPART(REF(CLOSE,1)*1.1*100)/100);

STICKLINE(X_48,CLOSE,OPEN,4,(-1)),COLORLIRED;

STICKLINE(X_48,CLOSE,OPEN,3,(-1)),COLORYELLOW;

STICKLINE(X_48,OPEN,CLOSE,2.5,0),COLORRED;

STICKLINE(X_48,OPEN,CLOSE,1,0),COLORMAGENTA;

X_49:=REF(CLOSE,1)/CLOSE<=1.099 AND REF(CLOSE,1)/CLOSE>=1.05;

STICKLINE(X_49,CLOSE,OPEN,4,(-1)),COLORGREEN;

STICKLINE(X_49,CLOSE,OPEN,3,(-1)),COLORFF9900;

STICKLINE(X_49,OPEN,CLOSE,2.5,0),COLORFFBB00;

STICKLINE(X_49,OPEN,CLOSE,1,0),COLORCYAN;

X_50:=NAMELIKE(4) OR NAMELIKE(5);

X_51:=CLOSE/REF(CLOSE,1)>=1.095 AND CLOSE=HIGH OR (CLOSE/REF(CLOSE,1)>=1.09 AND CLOSE=OPEN AND OPEN=LOW AND HIGH=LOW) OR (CLOSE/REF(CLOSE,1)>=1.048 AND X_50=1 AND CLOSE=HIGH) OR (CLOSE/REF(CLOSE,1)>=1.045 AND CLOSE=OPEN AND OPEN=LOW AND HIGH=LOW AND X_50=1);

STICKLINE(X_51,CLOSE,OPEN,4,(-1)),COLORYELLOW;

STICKLINE(X_51,OPEN,CLOSE,3.5,0),COLORRED;

STICKLINE(X_51,OPEN,CLOSE,2.5,1),COLOR007FFF;

STICKLINE(X_51,OPEN,CLOSE,1,0),COLORYELLOW;

X_52:=REF(CLOSE,1)/CLOSE>=1.095 AND CLOSE=LOW OR (REF(CLOSE,1)/CLOSE>=1.09 AND CLOSE=OPEN AND OPEN=LOW AND HIGH=LOW) OR (REF(CLOSE,1)/CLOSE>=1.048 AND X_50=1 AND CLOSE=LOW) OR (REF(CLOSE,1)/CLOSE>=1.045 AND CLOSE=OPEN AND OPEN=LOW AND HIGH=LOW AND X_50=1);

STICKLINE(X_52,CLOSE,OPEN,4,(-1)),COLORGREEN;

STICKLINE(X_52,OPEN,CLOSE,3.5,0),COLORBLUE;

STICKLINE(X_52,OPEN,CLOSE,2.5,1),COLORLICYAN;

STICKLINE(X_52,OPEN,CLOSE,1,0),COLORGREEN;

STICKLINE(CLOSE>OPEN AND HIGH/CLOSE>=1.03,HIGH,CLOSE,0,0),COLORGREEN,LINETHICK2;

STICKLINE(CLOSE>OPEN AND OPEN/LOW>=1.03,OPEN,LOW,0,0),COLORYELLOW,LINETHICK2;

STICKLINE(CLOSE<OPEN AND HIGH/OPEN>=1.03,HIGH,OPEN,0,0),COLORGREEN,LINETHICK2;

STICKLINE(CLOSE<OPEN AND CLOSE/LOW>=1.03,CLOSE,LOW,0,0),COLORYELLOW,LINETHICK2;



副图公式源码:


DRAWGBK(CLOSE>0,RGB(0,108,108),RGB(88,0,0),0,5,0);

X_1:=1;

X_2:=REF(LLV(LOW,90),3)*X_1;

X_3:=REFDATE(X_2,DATE);

X_4:=X_3=LOW AND (CLOSE-LOW>OPEN-CLOSE OR OPEN-LOW>CLOSE-OPEN);

X_5:=REF(HHV(LOW,70),3)*X_1;

X_6:=REFDATE(X_5,DATE);

X_7:=X_6=HIGH AND (HIGH-CLOSE>CLOSE-OPEN OR HIGH-OPEN>CLOSE-OPEN);

X_8:=REF(HHV(HIGH,150),3)*X_1;

X_9:=REFDATE(X_8,DATE);

X_10:=REFDATE(X_9,DATE);

X_11:=X_10=HIGH AND (CLOSE-LOW<OPEN-CLOSE OR OPEN-LOW<CLOSE-OPEN);

X_12:=REF(LLV(LOW,150),3)*X_1;

X_13:=REFDATE(X_12,DATE);

X_14:=REFDATE(X_13,DATE);

X_15:=X_14=LOW AND (CLOSE+LOW<OPEN+CLOSE OR OPEN+LOW<CLOSE+OPEN);

X_16:=REF(LOW,1)*X_1;

X_17:=SMA(ABS(LOW-X_16),13,1)/SMA(MAX(LOW-X_16,0),13,1)*100*X_1;

X_18:=EMA(IF(CLOSE*1.2,X_17*13,X_17/13),13);

X_19:=LLV(LOW,34)*X_1;

X_20:=HHV(X_18,34)*X_1;

X_21:=IF(LLV(LOW,56),1,0);

X_22:=EMA(IF(LOW<=X_19,(X_18+X_20*2)/2,0),3)/618*X_21;

X_23:=X_22>REF(X_22,1);

X_24:=REF(LLV(LOW,100),3);

X_25:=REFDATE(X_24,DATE);

X_26:=LOW=X_25;

X_27:=X_23 AND X_26;

X_28:=X_27>REF(X_27,1);

X_29:=X_28>REF(X_28,1);

X_30:=CROSS(EMA(CLOSE,19),EMA(CLOSE,7));

X_31:=CROSS(EMA(CLOSE,7),EMA(CLOSE,19));

X_32:=LOW=LLV(LOW,BARSLAST(X_30)+1);

X_33:=LLV(LOW,BARSLAST(X_30)+1);

X_34:=HIGH=HHV(HIGH,BARSLAST(X_31)+1);

X_35:=HHV(HIGH,BARSLAST(X_31)+1);

X_36:=DRAWLINE(X_32,X_33,X_34,X_35,0);

X_37:=HIGH=HHV(HIGH,BARSLAST(X_31)+1);

X_38:=HHV(HIGH,BARSLAST(X_31)+1);

X_39:=LOW=LLV(LOW,BARSLAST(X_30)+1);

X_40:=LLV(LOW,BARSLAST(X_30)+1);

X_41:=DRAWLINE(X_37,X_38,X_39,X_40,0);

X_42:=IF(X_41<REF(X_41,1) AND X_41=X_36,1,0);

X_43:=IF(REF(X_42,1)=0 AND X_42>=1,1,0);

X_44:=3;

X_45:=MA(HHV(HIGH,485),17)*X_1;

X_46:=MA(HHV(HIGH,222),17)*X_1;

X_47:=MA(HHV(HIGH,96),17)*X_1;

X_48:=MA(LLV(LOW,485),17)*X_1;

X_49:=MA(LLV(LOW,222),17)*X_1;

X_50:=MA(LLV(LOW,96),17)*X_1;

X_51:=MA((X_48*0.96+X_49*0.96+X_50*0.96+X_45*0.558+X_46*0.558+X_47*0.558)/6,17);

X_52:=MA((X_48*1.25+X_49*1.23+X_50*1.2+X_45*0.55+X_46*0.55+X_47*0.65)/6,17);

X_53:=MA((X_48*1.3+X_49*1.3+X_50*1.3+X_45*0.68+X_46*0.68+X_47*0.68)/6,17);

X_54:=MA((X_51*3+X_52*2+X_53)/6*1.738,17);

X_55:=IF(1,X_54,X_54*DAY);

X_56:=LOW;

X_57:=REF(LOW,1);

X_58:=SMA(ABS(X_56-X_57),3,1)/SMA(MAX(X_56-X_57,0),X_44,1)*100;

X_59:=MA(IF(CLOSE*1.35<=X_55,X_58*10,X_58/10),X_44);

X_60:=LLV(LOW,30)*X_1;

X_61:=HHV(X_59,30)*X_1;

X_62:=1;

X_63:=IF(1,MA(IF(LOW<=X_60,(X_59+X_61*2)/2,0),X_44),100000000);

X_64:=IF(CLOSE<REF(CLOSE,1),VOL/CAPITAL*10053,0);

X_65:=ABS(EMA(X_64,13.3)-18)/WINNER(CLOSE)*IF((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)<(-0.04),1,0);

X_66:=IF(X_63>500 AND X_63>2500,30,0);

X_67:=IF(X_63>10000 AND X_63>20000,60,0);

X_68:=IF(X_63>30000 AND X_63>30000,1,0);

X_69:=WINNER(CLOSE*(1-30/100))-WINNER(CLOSE*(1+30/100))*100;

X_70:=REF(LOW,1);

X_71:=SMA(ABS(LOW-X_70),13,1)/SMA(MAX(LOW-X_70,0),13,1)*100;

X_72:=EMA(IF(CLOSE*1.2,X_71*13,X_71/13),13);

X_73:=LLV(LOW,34)*X_1;

X_74:=HHV(X_72,34)*X_1;

X_75:=IF(LLV(LOW,56),1,0);

X_76:=EMA(IF(LOW<=X_73,(X_72+X_74*2)/2,0),3)/618*X_75;

X_77:=X_76>REF(X_76,1);

X_78:=100;

X_79:=3;

X_80:=REF(LLV(LOW,100),3);

X_81:=REFDATE(X_80,DATE);

X_82:=LOW=X_81;

X_83:=X_77 AND X_82;

X_84:=X_83>REF(X_83,1);

X_85:=X_84>REF(X_84,1);

X_86:=X_4+X_15+X_29+X_43+X_85+X_68>=3;

X_87:=CROSS(CLOSE/MA(CLOSE,20)-1,2.1*STD(CLOSE,20)/MA(CLOSE,20)) AND CROSS(CLOSE/MA(CLOSE,20)-1,1.3*STD(CLOSE,20)/MA(CLOSE,20));

X_88:=MA(CLOSE,10);

X_89:=MA(CLOSE,54);

X_90:=(CLOSE-X_89)/X_89<0.1;

X_91:=(CLOSE-X_88)/X_88<0.3;

X_92:=(X_87=1 AND X_88=1)*0.2;

X_93:=(X_92=0 AND REF(X_92,1)=0.2 AND REF(COUNT(X_92=0.2,10)=10,1)=1)*(-0.1);

X_94:=X_93=(-0.1);

X_95:=MA(VOL,5)*X_1;

X_96:=REF(X_95,1);

X_97:=VOL/X_96>2 AND VOL/CAPITAL*100>3;

X_98:=REF((HHV(HIGH,30)-LLV(LOW,30))/LLV(LOW,30),1)<=30/100 AND CLOSE>=REF(HHV(HIGH,30),1) AND BARSCOUNT(CLOSE)>30;

X_99:=X_97 AND X_98 AND DYNAINFO(14)>0.03 AND DYNAINFO(17)>0.03;

X_100:=X_94+X_99>0;

IF(X_100,100,0),COLORMAGENTA;

DRAWICON(X_100,100,34);

STICKLINE(X_86,30*3,0.4*3,4.7,0),COLORYELLOW;

STICKLINE(X_86,30*3,29.4*3,1,0),COLORYELLOW;

STICKLINE(X_86,29.4*3,33*3,0,4.7),COLORRED;

STICKLINE(X_86,29.4*3,33*3,4.7,0),COLORRED;

STICKLINE(X_86,1*3,0*3,10,0),COLORRED;

STICKLINE(X_86,2*3,0.4*3,8,0),COLORGREEN;

STICKLINE(X_86,20*3,0*3,4.4,0),COLORYELLOW;

STICKLINE(X_86,29*3,16*3,4,0),COLORBLACK;

STICKLINE(X_86,16*3,15*3,4,0),COLORBLACK;

STICKLINE(X_86,19.700001*3,4*3,4,0),COLORBLACK;

STICKLINE(X_86,3*3,0*3,1,0),COLOR000066;

STICKLINE(X_86,6*3,3*3,1,0),COLOR330066;

STICKLINE(X_86,9*3,6*3,1,0),COLOR660066;

STICKLINE(X_86,12*3,9*3,1,0),COLOR990099;

STICKLINE(X_86,13*3,12*3,4.7,0),COLORGREEN;

STICKLINE(X_86,15*3,12*3,1,0),COLORCC0066;

STICKLINE(X_86,18*3,15*3,1,0),COLORFF0066;

STICKLINE(X_86,16*3,15*3,4.7,0),COLORYELLOW;

STICKLINE(X_86,18*3,19*3,4.7,0),COLORGREEN;

STICKLINE(X_86,21*3,18*3,1,0),COLORFF00CC;

STICKLINE(X_86,24*3,21*3,1,0),COLORCC00CC;

STICKLINE(X_86,27*3,24*3,1,0),COLOR9900CC;

STICKLINE(X_86,30*3,27*3,1,0),COLOR6600CC;

    © 版权声明
    THE END
    喜欢就支持一下吧
    点赞12赞赏 分享
    评论 抢沙发
    头像
    欢迎您留下宝贵的见解!
    提交
    头像

    昵称

    取消
    昵称表情代码图片

      暂无评论内容