独霸一方指标:指标中红柱为“买点”信号买入,绿柱“卖点”卖出

独霸一方指标:指标中红柱为“买点”信号买入,绿柱“卖点”卖出

独霸一方指标:指标中红柱为“买点”信号买入,绿柱“卖点”卖出

指标中红柱为“买点”信号买入,绿柱“卖点”卖出,每个红柱之后基本上都会有个绿柱信号,因此大家可以据此机械化操作。


独霸一方”指标源码(副图):


X_1:=REF(CLOSE,1);

X_2:=SMA(MAX(CLOSE-X_1,0),5,1)/SMA(ABS(CLOSE-X_1),5,1)*100;

X_3:=SMA(X_2,5,1);

X_4:=BARSLAST(X_2<=15)<5;

X_5:=SMA(X_2,5,1);

X_6:=CROSS(X_2,X_3) AND X_5>15 AND X_4;

X_7:=FILTER(X_6,10);

X_8:=IF(CLOSE>REF((6*HIGH+5*REF(HIGH,1)+4*REF(HIGH,2)+3*REF(HIGH,3)+2*REF(HIGH,4)+1*REF(HIGH,5))/(6+5+4+3+2+1),1),1,IF(CLOSE<REF((6*LOW+5*REF(LOW,1)+4*REF(LOW,2)+3*REF(LOW,3)+2*REF(LOW,4)+1*REF(LOW,5))/(6+5+4+3+2+1),1),(-1),0));

X_9:=BARSLAST(NOT(X_8=0));

X_10:=IF(X_8=0,REF(X_8,X_9),X_8);

触发:X_7,NODRAW,COLORRED;

止损:CLOSE<REF(OPEN,BARSLAST(X_7>0)) AND COUNT(CLOSE<REF(OPEN,BARSLAST(X_7>0)),BARSLAST(X_7>0))=1 AND IF(MA(CLOSE,1)>IF(X_10=(-1),MA(HIGH,6),MA(LOW,6)),1,(-1))>0,NODRAW,COLORWHITE;

止盈:HIGH/REF(CLOSE,BARSLAST(X_7>0))>=1.05 OR CLOSE/REF(CLOSE,BARSLAST(X_7>0))>=1.05 AND COUNT(止损,BARSLAST(X_7>0))=0 AND COUNT(CROSS(0,IF(MA(CLOSE,1)>IF(X_10=(-1),MA(HIGH,6),MA(LOW,6)),1,(-1))),BARSLAST(X_7>0))=0,NODRAW,COLORBLUE;

区间:COUNT(X_7,BARSLAST(X_7)+1)=1 AND COUNT(止损,BARSLAST(X_7>0)+1)=0 AND COUNT(CROSS(0,IF(MA(CLOSE,1)>IF(X_10=(-1),MA(HIGH,6),MA(LOW,6)),1,(-1))),BARSLAST(X_7>0)+1)=0,NODRAW,COLOR696960;

结束:COUNT(X_7,BARSLAST(X_7)+1)=1 AND COUNT(止损,BARSLAST(X_7>0)+1)=0 AND COUNT(CROSS(0,IF(MA(CLOSE,1)>IF(X_10=(-1),MA(HIGH,5),MA(LOW,5)),1,(-1))),BARSLAST(X_7>0)+1)=1 AND CROSS(0,IF(MA(CLOSE,1)>IF(X_10=(-1),MA(HIGH,6),MA(LOW,5)),1,(-1))) OR 止损,NODRAW,COLORGREEN;

STICKLINE(触发>0,0,1,(-1),0),COLORRED;

STICKLINE(止盈>0,0.4,0.6,4,0),COLORBLUE;

STICKLINE(结束>0,0,0.7,(-1),0),COLORGREEN;

STICKLINE(止损>0,0.8,1,(-1),0),COLORWHITE;

X_11:=BARSLASTCOUNT(止盈>0);

DRAWTEXT(止盈>0,0.5,VAR2STR(X_11,0));


独霸一方”指标源码(选股):


X_1:=REF(CLOSE,1);

X_2:=SMA(MAX(CLOSE-X_1,0),5,1)/SMA(ABS(CLOSE-X_1),5,1)*100;

X_3:=SMA(X_2,5,1);

X_4:=BARSLAST(X_2<=15)<5;

X_5:=SMA(X_2,5,1);

X_6:=CROSS(X_2,X_3) AND X_5>15 AND X_4;

BU:FILTER(X_6,10);

    © 版权声明
    THE END
    喜欢就支持一下吧
    点赞8赞赏 分享
    评论 抢沙发
    头像
    欢迎您留下宝贵的见解!
    提交
    头像

    昵称

    取消
    昵称表情代码图片

      暂无评论内容