至尊猎庄系列通达信主图副图1号2号指标

至尊猎庄系列通达信主图副图1号2号指标

主图

JJ1:=MAX(MAX((H-L),ABS(REF(C,1)-H)),ABS(REF(C,1)-L));

JJ2:=MA(JJ1,13);

JJ3:=REF(C,1)-REF(JJ2,1);

重要参考线:HHV(JJ3,13),LINETHICK1,COLORGREEN;

J1:=MA(C,13);

决策关注:STICKLINE(J1>O AND C>J1 AND O<C,O,C,2,0),COLORYELLOW;

ST:=(CLOSE/OPEN+1)*100;

ZF:=(C/REF(C,1)+1)*100;

SX1:=ST>3 AND ST=HHV(ST,5);

SX2:=ZF>3 AND ZF=HHV(ZF,5);

SX3:=ZF>=9 AND CLOSE=HIGH;

S:=IF(SX1 OR SX2 OR SX3,1,0),COLOR0000FF;

DYSJ:=WEEKDAY;

监测:=IF(DYSJ<=13 AND COUNT(C>REF(L,DYSJ),DYSJ)>=DYSJ+1,DYSJ,0),COLOR00FFFF;

关注:=IF(DYSJ>=5 AND COUNT(H>REF(H,DYSJ),5)>=5,REF(H,DYSJ),REF(H,DYSJ)),COLOR00FFFF;

监测②:=IF(关注=REF(L,DYSJ),REF(L,DYSJ),REF(L,DYSJ)),COLORFFFFFF;

STICKLINE(监测,监测②,监测②,3,0),COLOR00FFFF;

BF1:=LOW<关注*1.01 AND COUNT(LOW<关注*1.01,监测)=1;

BF2:=LOW<关注 AND COUNT(LOW<关注,监测)=1;

BF:=IF(BF1 OR BF2,1,0),COLOR00FF00;

支撑:STICKLINE(监测,关注,关注,6,0),COLORFF00FF;

【箱顶】:PEAK(HIGH,10,1)*0.98,COLORRED,LINETHICK1;

【箱底】:TROUGH(LOW,10,1)*1.02,COLORCYAN,LINETHICK1;

PD:=ISLASTBAR;

DRAWNUMBER(PD,【箱顶】,【箱顶】),COLORFF8080;

DRAWNUMBER(PD,【箱底】,【箱底】),COLORFF8080;

BIAS1:=MA((CLOSE-MA(CLOSE,13))/MA(CLOSE,13),3)*100,COLORWHITE;

BIAS3:=MA((CLOSE-MA(CLOSE,27))/MA(CLOSE,27),3)*100,COLORFF00FF,LINETHICK2;

操作区:=IF(BIAS3<0,BIAS3,0),COLORRED,LINETHICK3;

观望区:=IF(BIAS3>0,BIAS3,0),COLORGREEN,LINETHICK3;

VAR2K:=TROUGHBARS(3,15,1)<10;{WWW.kxmmgzh.COM}

VAR3K:=PEAKBARS(3,15,1)<10;

VAR4K:=IF(VAR2K=1,50,0);

VAR5K:=IF(VAR3K=1,50,0);

TJ1K:=观望区<REF(观望区,1) OR 观望区-REF(观望区,1)<REF(观望区,1)-REF(观望区,2);

TJ2K:=操作区>REF(操作区,1);

顶:=IF(TJ1K AND VAR5K=50,15,0),STICK,LINETHICK1,COLORGREEN;

底:=IF(TJ2K AND VAR4K=50,10,0),STICK,LINETHICK1,COLORRED;

DRAWICON(TJ1K AND VAR5K=50,HHV(H,10)+0.1,2);

DRAWICON(TJ2K AND VAR4K=50,LLV(L,10)-0.06,1);



1号副图

X_1:=(2*CLOSE+HIGH+LOW+OPEN)/5;

X_2:=EMA(EMA(EMA(X_1,4),4),4);

X_3:=(X_2-REF(X_2,1))/REF(X_2,1)*100;

X_4:=MA(X_3,3);

X_5:=MA(X_3,1);

X_6:=IF(X_5>X_4 OR X_5>(-0.25),0.2,0);

X_7:=CROSS(X_6,0.01);

X_8:=EMA(CLOSE,2);

X_9:=EMA(SLOPE(CLOSE,9)*20+CLOSE,37);

信号:CROSS(X_8,X_9) AND X_7,STICK;

STICKLINE(信号,30,0,3,0),COLORYELLOW;

STICKLINE(信号,30,0,0.01,0),COLORLIGREEN;

DRAWICON(信号>0,31,26);

2号副图

X_1:=EMA(EMA(CLOSE,23),23);

X_2:=(X_1-REF(X_1,1))/REF(X_1,1)*1000;

X_3:=DYNAINFO(11);

X_4:=(EMA(CLOSE,10)-EMA(CLOSE,55))*10;

X_5:=EMA(X_4,5);

X_6:=(CLOSE-X_3)/X_3<(-0.03);

X_7:=(CLOSE-X_3)/X_3<(-0.03);

X_8:=LAST(X_3>=REF(X_3,1),5,1) AND (CLOSE-X_3)/X_3<0.005;

X_9:=(CLOSE-X_3)/X_3>0.005;

X_10:=X_2<REF(X_2,1) AND X_2>0.5;

X_11:=X_2>0;

X_12:=X_2>REF(X_2,1) AND X_2<(-0.2);

X_13:=X_2>REF(X_2,1) AND X_2<0;

X_14:=CROSS(X_4,X_5) AND X_4<(-0.3);

X_15:=FILTER(X_6 AND X_12 AND X_14,13);

持续:FILTER(X_7 AND X_12 AND X_14,13),STICK;

STICKLINE(持续,30,0,3,0),COLORMAGENTA;

STICKLINE(持续,30,0,0.001,0),COLORYELLOW;

DRAWICON(持续>0,31,26);

    © 版权声明
    THE END
    喜欢就支持一下吧
    点赞7赞赏 分享
    评论 抢沙发
    头像
    欢迎您留下宝贵的见解!
    提交
    头像

    昵称

    取消
    昵称表情代码图片

      暂无评论内容