通达信指标公式源码倍量主图指标公式

通达信指标公式源码倍量主图指标公式

DRAWTEXT(HIGH>=REF(CLOSE,1)*1.095,HIGH,’涨停’),COLORMAGENTA;

STICKLINE(V/REF(V,1)>2,OPEN,CLOSE,1,0),COLORGREEN;

DRAWTEXT(REF(CLOSE,1)>=LOW*1.095,LOW,’跌停’),COLORGREEN;

A:=((REF(H,1)-REF(L,1))/2+REF(L,1));

B:=IF(A,A,REF(A,BARSLAST(A)));

D:STICKLINE(BARSLAST(A)+1 OR A,B,B,10,0);

黄金柱:=V/REF(V,1)>=1.9;

K1:=SUMBARS(黄金柱,1) ;

K2:=SUMBARS(黄金柱,2);

K3:=SUMBARS(黄金柱,3);

K4:=SUMBARS(黄金柱,4);

K5:=SUMBARS(黄金柱,5);

K6:=SUMBARS(黄金柱,6);

K7:=SUMBARS(黄金柱,7);

K8:=SUMBARS(黄金柱,8);

K9:=SUMBARS(黄金柱,9);

K10:=SUMBARS(黄金柱,10);

AA:STICKLINE(K1,REF(L,K1-1)*1.002,REF(L,K1-1),5,0),COLORYELLOW;

M1:=2*10;M2:=4*10;M3:=8*10;

A0:=REF(H,M3)=HHV(H,2*M3+1);

B0:=FILTER(A0,M3);

C0:=BACKSET(B0,M3+1);

D0:=FILTER(C0,M3);{高点}

R01:=BACKSET(ISLASTBAR,BARSLAST(D0)+1); S01:=R01>REF(R01,1);

DRAWLINE(D0,H,S01,H,1),COLORGREEN,LINETHICK1;

A02:=REF(L,M3)=LLV(L,2*M3+1);

B02:=FILTER(A02,M3);

C02:=BACKSET(B02,M3+1);

D02:=FILTER(C02,M3);{低点}

T011:=BACKSET(ISLASTBAR,BARSLAST(D02)+1); U011:=T011>REF(T011,1);

DRAWLINE(D02,L,U011,L,1),COLORGREEN;

A1:=REF(H,M1)=HHV(H,2*M1+1);

B1:=FILTER(A1,M1);

C1:=BACKSET(B1,M1+1);

D1:=FILTER(C1,M1);{高点}

R11:=BACKSET(ISLASTBAR,BARSLAST(D1)+1); S11:=R11>REF(R11,1);

DRAWLINE(D1,H,S11,H,1),COLORBLUE;

A2:=REF(L,M1)=LLV(L,2*M1+1);

B2:=FILTER(A2,M1);

C2:=BACKSET(B2,M1+1);

D2:=FILTER(C2,M1);{低点}

T11:=BACKSET(ISLASTBAR,BARSLAST(D2)+1); U11:=T11>REF(T11,1);

DRAWLINE(D2,L,U11,L,1),COLORBLUE;

A12:=REF(H,10)=HHV(H,2*10+1);

B12:=FILTER(A12,10);

C12:=BACKSET(B12,10+1);

D12:=FILTER(C12,10);{高点}

R112:=BACKSET(ISLASTBAR,BARSLAST(D12)+1); S112:=R112>REF(R112,1);

DRAWLINE(D12,H,S112,H,1),COLORRED;

A22:=REF(L,10)=LLV(L,2*10+1);

B22:=FILTER(A22,10);

C22:=BACKSET(B22,10+1);

D22:=FILTER(C22,10);{低点}

T112:=BACKSET(ISLASTBAR,BARSLAST(D22)+1); U112:=T112>REF(T112,1);

DRAWLINE(D22,L,U112,L,1),COLORRED;

A32:=REF(H,M2)=HHV(H,2*M2+1);

B32:=FILTER(A32,M2);

C32:=BACKSET(B32,M2+1);

D32:=FILTER(C32,M2);{高点}

R312:=BACKSET(ISLASTBAR,BARSLAST(D32)+1); S312:=R312>REF(R312,1);

DRAWLINE(D32,H,S312,H,1),COLORYELLOW;

A322:=REF(L,M2)=LLV(L,2*M2+1);

B322:=FILTER(A22,M2);

C322:=BACKSET(B22,M2+1);

D322:=FILTER(C22,M2);{低点}

T312:=BACKSET(ISLASTBAR,BARSLAST(D322)+1); U312:=T312>REF(T312,1);

DRAWLINE(D322,L,U312,L,1),COLORYELLOW;

STICKLINE(C<0.905*REF(C,1),C,O,3,0),COLORGREEN;

STICKLINE(C>1.095*REF(C,1),C,O,3,0),COLORYELLOW;

    © 版权声明
    THE END
    喜欢就支持一下吧
    点赞11赞赏 分享
    评论 抢沙发
    头像
    欢迎您留下宝贵的见解!
    提交
    头像

    昵称

    取消
    昵称表情代码图片

      暂无评论内容