强势龙头启动 买入上涨拉升【指标公式】(含选股)

第一部分 副图公式 手机/电脑


GUP1:=(3*CLOSE+HIGH+LOW+OPEN)/6;
GUP2:=EMA(GUP1,35);
GUP3:=(HHV(GUP2,10)+HHV(GUP2,30)+HHV(GUP2,90))/3;
GUP4:=(LLV(GUP2,10)+LLV(GUP2,30)+LLV(GUP2,90))/3;
GUP5:=(HHV(GUP3,5)+HHV(GUP3,15)+HHV(GUP3,30))/3;
GUP6:=(LLV(GUP4,5)+LLV(GUP4,15)+LLV(GUP4,30))/3;
GUP7:=EXPMA(CLOSE,6);
GUP8:=EXPMA(CLOSE,18);
GUA1:=500*(GUP7-GUP8)/GUP8+2;
GUA2:=EMA(GUA1,3);
GUA3:=GUA1>2 AND EMA(EMA(GUP1,2),2)>GUP6;
追涨:GUA3 AND GUA3>=REF(GUA3,1),COLORMAGENTA,NODRAW;
STICKLINE(追涨,1.46,2,8,0),COLORMAGENTA;
GUA4:=GUA1<0 OR GUA2<0 OR EMA(EMA(GUP1,2),2)<GUP6;
STICKLINE(GUA4,1.46,2,8,1),COLORLICYAN;
STICKLINE(GUA1<2 AND GUA1>0 AND GUA1<REF(GUA1,1),1.46,2,8,1),COLORLICYAN;
STICKLINE(GUA2>0 AND GUA2<2 AND GUA3<REF(GUA3,1),1.46,2,8,1),COLORLIRED;
STICKLINE(GUA1>0 AND GUA1<2 AND GUA1>REF(GUA1,1),1.46,2,8,1),COLORLIRED;
GUB4:=INDEXC;
GUB6:=(3*CLOSE+HIGH+LOW+OPEN)/6;
GUB7:=EMA(GUB6,35);
GUB8:=(HHV(GUB7,5)+HHV(GUB7,15)+HHV(GUB7,30))/3;
牛:=(HHV(GUB8,5)+HHV(GUB8,15)+HHV(GUB8,30))/3;
GUB11:=GUB4/EMA(GUB4,120);
大盘:=EMA(EMA(CLOSE,120)*GUB11,2);
GUB12:=GUB6>=牛 AND GUB6>=大盘;
强势:GUB12=1,COLORMAGENTA,NODRAW;
GUB13:=GUB6<牛 AND GUB6>=大盘 AND 牛>大盘;
GUB14:=GUB6<=大盘 AND GUB6<=牛 OR (GUB6>=牛 AND GUB6<大盘 AND 牛<大盘);
STICKLINE(强势,0.76,1.38,8,0),COLORMAGENTA;
STICKLINE(GUB13=1,0.76,1.39,8,1),COLORRED;
STICKLINE(GUB14=1,0.76,1.39,8,0),COLORGRAY;
GUC1:=(2*CLOSE+OPEN+HIGH+LOW)*100;
GUC2:=GUC1/EMA(GUC1,4)-1;
红龙:GUC2>REF(GUC2,1) AND GUC2>0,COLORRED,NODRAW;
STICKLINE(红龙,0,0.67,8,0),COLORRED;
STICKLINE(GUC2<REF(GUC2,1) AND GUC2>0,0,0.67,8,0),COLORYELLOW;
STICKLINE(GUC2<REF(GUC2,1) AND GUC2<0,0,0.67,8,0),COLORGREEN;
STICKLINE(GUC2>REF(GUC2,1) AND GUC2<0,0,0.67,8,0),COLORFFAA00;
GUD1:=CLOSE/REF(CLOSE,1)>=1.038 AND C=H;
GUD22:=COUNT(GUD1,2)>=1 AND NOT(COUNT(GUD1,3)>=2);
启:=FILTER(GUD22,13),COLORDDDDDD;
GUD23:=COUNT(GUD1,3)>=2 AND NOT(COUNT(GUD1,4)>=3);
龙头:启 AND COUNT(启,18)=1,COLORWHITE,NODRAW;
STICKLINE(龙头,0,2,3,0),COLORWHITE;
DRAWICON(龙头,2.5,17);
DRAWICON(龙头,3,17);
DRAWTEXT(龙头,3,’强龙’),COLORWHITE;
升:=FILTER(GUD23,13),COLORGREEN;
主升:=升 AND COUNT(升,18)=1;
拉升:主升,COLORYELLOW,NODRAW;
STICKLINE(拉升,0,2,3,0),COLORYELLOW;
DRAWICON(拉升,2.5,25);
DRAWICON(拉升,3,25);
DRAWICON(拉升,3.5,25);
DRAWICON(拉升,4.5,1);
DRAWTEXT(拉升,5.5,’买涨’),COLORYELLOW;
 

第二部分 选股公式


{选股公式一:强龙}
GUB6:=(3*CLOSE+HIGH+LOW+OPEN)/6;
GUB7:=EMA(GUB6,35);
GUB8:=(HHV(GUB7,5)+HHV(GUB7,15)+HHV(GUB7,30))/3;
GUC1:=(2*CLOSE+OPEN+HIGH+LOW)*100;
GUC2:=GUC1/EMA(GUC1,4)-1;
GUD1:=CLOSE/REF(CLOSE,1)>=1.038 AND C=H;
GUD22:=COUNT(GUD1,2)>=1 AND NOT(COUNT(GUD1,3)>=2);
启:=FILTER(GUD22,13),COLORDDDDDD;
龙头:=启 AND COUNT(启,18)=1,COLORWHITE;
强龙:龙头;
{选股公式二:买涨}
GUP1:=(3*CLOSE+HIGH+LOW+OPEN)/6;
GUP2:=EMA(GUP1,35);
GUP3:=(HHV(GUP2,10)+HHV(GUP2,30)+HHV(GUP2,90))/3;GUC1:=(2*CLOSE+OPEN+HIGH+LOW)*100;
GUC2:=GUC1/EMA(GUC1,4)-1;
GUD1:=CLOSE/REF(CLOSE,1)>=1.038 AND C=H;
GUD23:=COUNT(GUD1,3)>=2 AND NOT(COUNT(GUD1,4)>=3);
升:=FILTER(GUD23,13),COLORGREEN;
主升:=升 AND COUNT(升,18)=1;
拉升:=主升,COLORYELLOW;
买涨:拉升;
 

第三部分 图片示例

强势龙头启动 买入上涨拉升【指标公式】(含选股)

    © 版权声明
    THE END
    喜欢就支持一下吧
    点赞15赞赏 分享
    评论 抢沙发
    头像
    欢迎您留下宝贵的见解!
    提交
    头像

    昵称

    取消
    昵称表情代码图片

      暂无评论内容