通达信麟龙饱和度指标公式

通达信麟龙饱和度指标公式

N:=20;

量能饱和度:IF((AMOUNT/C)/(HHV(AMOUNT,N)/HHV(C,N))*100>100,100,(AMOUNT/C)/(HHV(AMOUNT,N)/HHV(C,N))*100);

STICKLINE(((CLOSE > 0) AND ISLASTBAR),20,121,6,1),COLORFFFFFF;

STICKLINE(((量能饱和度 <= 5) AND ISLASTBAR),21,(20 + 量能饱和度),5,0),COLORFFFFFF;

STICKLINE((((量能饱和度 > 5) AND (量能饱和度 <= 20)) AND ISLASTBAR),21,(20 + 量能饱和度),5,0),COLORCCFF88;

STICKLINE((((量能饱和度 > 20) AND (量能饱和度 <= 40)) AND ISLASTBAR),21,(20 + 量能饱和度),5,0),COLORFF00FF;

STICKLINE(((量能饱和度 > 40) AND ISLASTBAR),21,(20 + 量能饱和度),5,0),COLOR0000FF;

{SAT:=(AMOUNT/CLOSE)/HHV((AMOUNT/CLOSE),26);

饱和度:IF(SAT>1,1,SAT)*100,COLORYELLOW;

STICKLINE(C>0 AND ISLASTBAR=1,5,100,10,1),COLORWHITE;

量能≤5:STICKLINE(饱和度<=5 AND ISLASTBAR=1,5,饱和度+20,6,0),COLORRED;

量能5~80:STICKLINE((饱和度>5 AND 饱和度< 80) AND ISLASTBAR=1,5,饱和度+8,6,0),COLOR5290FF;

量能80~97:STICKLINE((饱和度>80 AND 饱和度< 97) AND ISLASTBAR=1,5,饱和度,6,0),COLORFFCC00;

量能≥97:STICKLINE(饱和度>=97 AND ISLASTBAR=1,5,饱和度,8,0),COLORGREEN;

DRAWTEXT(ISLASTBAR=1 AND 饱和度,0,’量能饱和度:’+饱和度),COLORFFCCFF;

5,POINTDOT,COLORFFEEBB;

97,POINTDOT,COLORGREEN;};

    © 版权声明
    THE END
    喜欢就支持一下吧
    点赞14赞赏 分享
    评论 抢沙发
    头像
    欢迎您留下宝贵的见解!
    提交
    头像

    昵称

    取消
    昵称表情代码图片

      暂无评论内容