通达信卡卡小鸡操盘主图指标公式

通达信卡卡小鸡操盘主图指标公式

DING: PEAK(CLOSE,10,1)*0.98,LINETHICK1,COLORRED;{箱体}

DI:TROUGH(CLOSE,10,1)*1.02,LINETHICK2,COLORGREEN;

RSV:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;

K:=SMA(RSV,3,1);

D:=SMA(K,3,1);

J:=3*K-2*D;

RSV24:=(CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100;

K24:=SMA(RSV24,3,1);

D24:=SMA(K24,3,1);

J24:=3*K24-2*D24;

压力位:IF(CROSS(J24,J),H,REF(H,BARSLAST(CROSS(J24,J)))),COLORBLUE,LINETHICK2;

支撑位:IF(CROSS(J,J24),L,REF(L,BARSLAST(CROSS(J,J24)))),COLORCC33CC,LINETHICK2;

A1:=BARSLAST(REF(CROSS(“MACD.DIF”,”MACD.DEA”),1));

DRAWTEXT(REF(C,A1+1)>C AND REF(“MACD.DIF”,A1+1)<“MACD.DIF” AND CROSS(“MACD.DIF”,”MACD.DEA”)>0,L-0.02,’★M’),COLOR00FFFF;{MACD底背离}

A2:=BARSLAST(REF(CROSS(“KDJ.K”,”KDJ.D”),1));

DRAWTEXT(REF(C,A2+1)>C AND REF(“KDJ.K”,A2+1)<“KDJ.K” AND CROSS(“KDJ.K”,”KDJ.D”),L-0.10,’◎K’),COLORFF00FF;{KDJ底背离}

A3:=BARSLAST(REF(CROSS(“RSI.RSI1″,”RSI.RSI2”),1));

DRAWTEXT(REF(C,A3+1)>C AND REF(“RSI.RSI1”,A3+1)<“RSI.RSI1” AND CROSS(“RSI.RSI1″,”RSI.RSI2”)>0,L-0.18,’◆R’),COLOR0000FF;{RSI底背离};

C1:=BARSLAST(REF(CROSS(“MACD.DEA”,”MACD.DIF”),1));

DRAWTEXT(REF(C,C1+1)<C AND REF(“MACD.DIF”,C1+1)>”MACD.DIF” AND CROSS(“MACD.DEA”,”MACD.DIF”)>0,H+0.16,’★M’),COLOR00FF00;{MACD顶背离};

C2:=BARSLAST(REF(CROSS(“KDJ.D”,”KDJ.K”),1));

DRAWTEXT(REF(C,C2+1)<C AND REF(“KDJ.K”,C2+1)>”KDJ.K” AND CROSS(“KDJ.D”,”KDJ.K”)>0,H+0.08,’◎K’),COLORFFFFCC;{KDJ顶背离}

C3:=BARSLAST(REF(CROSS(“RSI.RSI2″,”RSI.RSI1”),1));

DRAWTEXT(REF(C,C3+1)<C AND REF(“RSI.RSI1″,C3+1)>”RSI.RSI1” AND CROSS(“RSI.RSI2″,”RSI.RSI1”)>0,H+0.04,’◆R’),COLORFF9900;{RSI顶背离};

重心:=(C+0.618*REF(C,1)+0.382*REF(C,1)+0.236*REF(C,3)+0.146*REF(C,4))/2.382;

BBI: (MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4,COLORWHITE,LINETHICK2;

操盘线:EMA(((SLOPE(C,22)*20)+C),55),COLORYELLOW,LINETHICK4;

黄金线:IF(重心>=操盘线,操盘线,DRAWNULL),COLORRED,LINETHICK2;

空仓线:IF(重心<操盘线,操盘线,DRAWNULL),COLORCYAN,LINETHICK2;

{DRAWTEXT(ISLASTBAR,【操盘线】,’【操盘线】’),COLORRED;}

{引:EMA(CLOSE,2),LINETHICK1,COLORMAGENTA;

探:MA(CLOSE,5),LINETHICK1;};

变:EMA(CLOSE,5),LINETHICK1,COLORYELLOW;

金:IF(变>REF(变,1),变,DRAWNULL),COLORRED,LINETHICK1;

空:IF(变<REF(变,1),变,DRAWNULL),COLORGREEN,LINETHICK1;

人: IF(LLVBARS(V,13), REF (C,LLVBARS(V,13)),C),COLORMAGENTA,POINTDOT,LINETHICK4;

黑马线:EMA(C,453),CIRCLEDOT,LINETHICK1,COLOR428899;

DING0:MA(REF(HHV(C,30),1),2),COLORYELLOW,LINETHICK2;

DI0:MA(REF(LLV(C,30),1),2),COLORYELLOW,LINETHICK2;

    © 版权声明
    THE END
    喜欢就支持一下吧
    点赞15赞赏 分享
    评论 抢沙发
    头像
    欢迎您留下宝贵的见解!
    提交
    头像

    昵称

    取消
    昵称表情代码图片

      暂无评论内容