通达信抓妖副图指标公式

通达信抓妖副图指标公式

DIF:=EMA(CLOSE,12) – EMA(CLOSE,27);

DEA:=EMA(DIF,9);

MACD:=2*(DIF-DEA);

CCI线:=CCI(84);

分割线:=100.00;

妖股启动:=CROSS(CCI线,分割线) AND MACD>0 AND MACD>=REF(MACD,1) AND REF(MACD,1)<REF(MACD,2) AND C>=REF(C,1)*1.05;

STICKLINE(妖股启动,1,4,2,0),COLORYELLOW;

{DRAWTEXT(妖股启动,3.5,’妖股启动’),COLORMAGENTA;}

月DIF:=”MACD.DIF#MONTH”;

月DEA:=”MACD.DEA#MONTH”;

周DIF:=”MACD.DIF#WEEK”;

周DEA:=”MACD.DEA#WEEK”;

日DIF:=”MACD.DIF”;

日DEA:=”MACD.DEA”;

日金叉:=CROSS(日DIF,日DEA);

周金叉:=CROSS(周DIF,周DEA);

月金叉:=CROSS(月DIF,月DEA);

金叉共振:=IF(CROSS(周DIF,周DEA),MACD,0) AND C>REF(C,1)*1.078;

共振:=IF((日DIF>日DEA AND 周DIF>周DEA AND 月金叉) OR ( 周DIF>周DEA AND 月DIF>月DEA AND 日金叉)

OR (月DIF>月DEA AND 日DIF>日DEA AND 周金叉) OR (日金叉 AND 周金叉 AND 月金叉),MACD+0.2,0) AND C>REF(C,1)*1.078;

STICKLINE(共振,1,3,2,0),COLORRED;

STICKLINE(金叉共振,0,2,3,0),COLORCC3299;

{DRAWTEXT(共振,2.5,’何氏抓妖’),COLORYELLOW;}

{时间}

N1:=STRCAT(CON2STR(YEAR,0),’ 年 ‘);

Y1:=STRCAT(CON2STR(MONTH,0),’ 月 ‘);

R:=STRCAT(CON2STR(DAY,0),’ 日 ‘);

SJ:=STRCAT(STRCAT(N1,Y1), R);

DRAWTEXT_FIX(C>0,0.88,0,0,SJ),COLORYELLOW;

{七号}

EE:=MACD-REF(MACD,1)>0.05 AND COUNT(C/REF(C,1)>1.09,16)<2 AND C=HHV(H,60) AND

C/REF(C,1)>1.07 AND NOT(H=L) AND COUNT(C>O,6)<=4 AND C/REF(C,9)<1.2;

STICKLINE(EE AND C/REF(C,1)>1.05,1,2,4,0),COLORDB7093;

{DRAWTEXT(EE AND C/REF(C,1)>1.05,1.5,’打板启动’),COLORRED;}

VOLUME:=VOL;

MA1:=MA(VOLUME,5);

启动:= (MA1+MA1)>VOLUME;

买入:=DYNAINFO(4)>0 AND HHV(HIGH,10)/LLV(LOW,10)<1.25 AND CLOSE>=HHV(HIGH,10)

AND REF(CLOSE,1)<(LLV(LOW,15)+(HHV(HIGH,15)-LLV(LOW,15))*0.85) AND C>O;

选股:=(C>REF(HHV(H,3),1) AND (C-REF(C,1))/REF(C,1)>0.07) AND 启动 AND 买入;

STICKLINE(选股 AND C/REF(C,1)>1.05,0,1,5,0),COLORYELLOW;

{DRAWTEXT(选股,0.5,’蹬蹬启动’),COLORMAGENTA;};

    © 版权声明
    THE END
    喜欢就支持一下吧
    点赞12赞赏 分享
    评论 抢沙发
    头像
    欢迎您留下宝贵的见解!
    提交
    头像

    昵称

    取消
    昵称表情代码图片

      暂无评论内容